Re: No such file or directory: '/home/mturk/'

Hi Zeo,

I have it working with "from novaclient.v1_1 import client" in it, so I'm not sure about this:

I add this line to
'import novaclient'
and comment out
#from novaclient.v1_1 import client

Yes, you need environment variables set for OS_AUTH_URL, OS_USERNAME, etc., which would normally be set by sourcing However, you could instead specify them as command line arguments if you want. They do not come from production.env.

As Kacper mentioned, you do need network connectivity to the OpenStack management network, which is on a private subnet on the vlad-mgmt node. All of your network timeout type errors are probably related to this if you're not running the script on vlad-mgmt.

Ticket NDS-20 is all about improving the situation with these networking-related hassles on the current VLAD cluster.

If you want, update to my branch ("mfreemon-dev") of nds-labs from bitbucket and try that. I put an explicit authentication call to OpenStack to help isolate network and authentication related errors from other types of errors. If fails on the authenticate() call, the problem is probably related to networking or user authentication. If the scripts passes that point, and fails on the nt.servers.create() call, then the problem is something else.

- Mike

On 6/21/2015 7:09 PM, Kacper Kowalik wrote:
On 06/19/2015 02:58 PM, Lengyue Chen wrote:
Or would it possible wrong with the net-id? Maybe the network is not
working now?

On Fri, Jun 19, 2015 at 2:35 PM, Lengyue Chen <lchen95@xxxxxxxxxxxx>

Hi all

I have solved the last issue with client object. And here is the
new one again... It timed out in this function call:

instance = nt.servers.create( "coreos_%s" % args.cluster_name,
args.image_id, args.flavor_id, min_count=n, max_count=n,
security_groups=["default", "coreos"],
userdata=open('cloud-config_%s.yaml' % public, 'r'),
key_name=args.ssh_key_name, nics=[{"net-id": args.net_id}] )

What I can think of is the key does not match but I guess there
should be a corresponding error message indicating the wrong key. I
tried to extract the from both my own
service_test_key_zeo.pem and nds.pem which Kacper gave me but they
did not work.

Here are the full error message and all my env variables. Thanks.

Lengyues-MacBook-Air:~ LY$ python ...

Hi Lengyue, I apologize if I wasn't sufficiently clear before, but you *won't* be able to run this script anywhere else besides vlad-mngt machine. Openstack that's installed there exposes REST API (which novaclient internally uses) through a set of local ip addresses. Cheers, Kacper

Other Mailing lists | Author Index | Date Index | Subject Index | Thread Index