Re: No such file or directory: '/home/mturk/'

Hi Kacper

I am confused about this line:

[kacperk@vlad-mgmt ~]$ python -c 'import novaclient; print novaclient.__file__'

Are you trying to import a file from vlad to the local directory:



If you are, then how do I ssh in vlad to execute this command and is there a key required? I tried but i can not find the ip address ofÂ


On Thu, Jun 18, 2015 at 3:31 PM, Kacper Kowalik <xarthisius.kk@xxxxxxxxx> wrote:
On 06/18/2015 03:12 PM, Lengyue Chen wrote:
Thank you Kacper, I got those files ready. But when I ran, it gave me this error:

 File "", line 6, in <module>

  Âfrom novaclient.v1_1 import client
 ÂFile "/Users/LY/novaclient/", line 18, in <module>
  Â__version__ = pbr.version.VersionInfo('python-novaclient').version_string()
 ÂFile "/Users/LY/pbr/", line 457, in version_string
  Âreturn self.semantic_version().brief_string()
 ÂFile "/Users/LY/pbr/", line 452, in semantic_version
  Âself._semantic = self._get_version_from_pkg_resources()
 ÂFile "/Users/LY/pbr/", line 439, in _get_version_from_pkg_resources
  Âresult_string = packaging.get_version(self.package)
 ÂFile "/Users/LY/pbr/", line 576, in get_version
  Âraise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist
tarball, or access to an upstream git repository. Are you sure that
git is installed?

It seems like something wrong with the novaclient module but I tried
uninstalled and installed python-novaclient module using pip several times
and it does not work..

don't install novaclient yourself. There's one already properly configured at vlad.

[kacperk@vlad-mgmt ~]$ python -c 'import novaclient; print novaclient.__file__'

Also, when I source, after typing my password it just
returned with no message. Is it normal?

If in doubt look inside ;-) This script export bunch of vars, nothing else. Yeah, no output is a good thing.


On Wed, Jun 17, 2015 at 4:00 PM, Kacper Kowalik <xarthisius.kk@xxxxxxxxx>

On 06/17/2015 03:56 PM, Kacper Kowalik wrote:
On 06/17/2015 03:39 PM, Lengyue Chen wrote:
Hi all

I am trying to run to see if it is still working and
need the ssh-key file

You need to generate it (ssh-keygen), if you don't have one already.

It's easier if you use the same pair that you have registered in
OpenStack. Please see detailed instruction here:


Other Mailing lists | Author Index | Date Index | Subject Index | Thread Index