Re: No such file or directory: '/home/mturk/'

Hi all

I have solved the last issue with client object. And here is the new one again... It timed out in this function call:

instance = nt.servers.create(
            "coreos_%s" % args.cluster_name,
            min_count=n, max_count=n,
            security_groups=["default", "coreos"],
            userdata=open('cloud-config_%s.yaml' % public, 'r'),
            nics=[{"net-id": args.net_id}]
What I can think of is the key does not match but I guess there should be a corresponding error message indicating the wrong key. I tried to extract the from both my own service_test_key_zeo.pem and nds.pem which Kacper gave me but they did not work.

Here are the full error message and all my env variables. Thanks.

Lengyues-MacBook-Air:~ LY$ python --ip --total-vms 3 --total-public 1 --name labs --ssh-key ~/ --env-file ~/production.env --region NCSA --net-id 165265ee-d257-43d7-b3b7-e579cd749ed4 --image-id fdc6aa22-4913-45bc-83ad-77f6ae218348 --dbvol-id e5b37fd8-1d7f-49f3-95bb-6c3127ee7199 --icatvol-id b89e0b67-9e93-4ab1-8e45-919a61c17e66 --moinmoin-id 1b74658a-9638-4db6-b7f3-1c2211f3776b --flavor-id 48ff5b63-73fc-4d35-93ec-3839ab0d0de7
/Users/LY/novaclient/v1_1/ UserWarning: Module novaclient.v1_1 is deprecated (taken as a basis for novaclient.v2). The preferable way to get client class or object you can find in novaclient.client module.
  warnings.warn("Module novaclient.v1_1 is deprecated (taken as a basis for "
etcd token is
Creating  1
---------------------------ALL my env varibales------------------------------------
Namespace(cluster_name='labs', dbvol_id='e5b37fd8-1d7f-49f3-95bb-6c3127ee7199', desired_ip='', env_file='/Users/LY/production.env', etcd_token=u'', flavor_id='48ff5b63-73fc-4d35-93ec-3839ab0d0de7', icatvol_id='b89e0b67-9e93-4ab1-8e45-919a61c17e66', image_id='fdc6aa22-4913-45bc-83ad-77f6ae218348', moinmoinvol_id='1b74658a-9638-4db6-b7f3-1c2211f3776b', net_id='165265ee-d257-43d7-b3b7-e579cd749ed4', openstack_pass='CLy83585518', openstack_tenant='NDS', openstack_url='', openstack_user='lchen95', region='NCSA', ssh_key='/Users/LY/', ssh_key_name='core', total_public=1, total_vms=3)
Traceback (most recent call last):
  File "", line 186, in <module>
    nics=[{"net-id": args.net_id}]
  File "/Users/LY/novaclient/v2/", line 926, in create
  File "/Users/LY/novaclient/v2/", line 540, in _boot
    return_raw=return_raw, **kwargs)
  File "/Users/LY/novaclient/", line 161, in _create
    _resp, body =, body=body)
  File "/Users/LY/novaclient/", line 454, in post
    return self._cs_request(url, 'POST', **kwargs)
  File "/Users/LY/novaclient/", line 407, in _cs_request
  File "/Users/LY/novaclient/", line 560, in authenticate
    auth_url = self._v2_auth(auth_url)
  File "/Users/LY/novaclient/", line 651, in _v2_auth
    return self._authenticate(url, body)
  File "/Users/LY/novaclient/", line 664, in _authenticate
  File "/Users/LY/novaclient/", line 402, in _time_request
    resp, body = self.request(url, method, **kwargs)
  File "/Users/LY/novaclient/", line 373, in request
  File "/Users/LY/requests/", line 50, in request
    response = session.request(method=method, url="" **kwargs)
  File "/Users/LY/requests/", line 465, in request
    resp = self.send(prep, **send_kwargs)
  File "/Users/LY/requests/", line 573, in send
    r = adapter.send(request, **kwargs)
  File "/Users/LY/requests/", line 415, in send
    raise ConnectionError(err, request=request)
requests.exceptions.ConnectionError: ('Connection aborted.', error(60, 'Operation timed out'))

Other Mailing lists | Author Index | Date Index | Subject Index | Thread Index